egp8111

Members
  • Content count

    85
  • Joined

  • Last visited


Community Reputation

7 Neutral

About egp8111

  • Rank
    Advanced Member
  • Birthday 02/04/1954

Profile Information

  • Gender Male
  • Location nc

egp8111's Activity

  1. egp8111 added a post in a topic What's it trying to tell me ?   

    Gearbox has been rebuilt. Prop is a new IVO three blade. Adjusted the idle mixture screws to 3/4 out and it is definatly better but still some roughness around 2500 rpm. Thing is I can slightly pull on the choke(enricher) knob on and it will run very smooth at 2500. However when I push up the throttle to 2500 it's rough.  I'm thinking the problem is it's too lean at idle but I can't figure out why. I've checked for induction leaks, replaced the rubber carb mounts etc.  sprayed starter fluid around but nothing turned up.  Errrrrrrrrr
    • 0
  2. egp8111 added a post in a topic What's it trying to tell me ?   

    hummm, is says 21/2 turns, must be typo.  Any idea on the mag. drop ?  This is my third 912 and the other two were less than 75 rpm, this one is more like 150-200.  About the same on either ing. box.
    Thanks
    EG
     
    • 0
  3. egp8111 added a topic in 4-strokes   

    What's it trying to tell me ?
    I've been chasing a rough idling (2000-3000 rpm) on this 912 for a year.  It will run fine above 3000 and idle OK around 1800 but between its got a very annoying miss.  It also has a high mag. drop (around 150 rpm.)  I've done all the usual things, sync'ed the carbs (over and over) had the carbs rebuilt, by myself and two separate professional companies, replace the plugs, plug wires and leads etc. checked for manifold leaks etc.,etc. Nothing had any effect, nada zip.....  The only thing I've found that has made any change is to turn the idle mixture screws almost all the way in.  The manual and all the experts say turn them out 21/2 turns and leave them, but mine have to be about only 3/4 of a turn out or its rough as a cob between 2000 & 3000 rpm.  I'm thinking something is screwy in the idle circuit because it runs smooth above 3000.  But what else to try? Any ideas ?
    Thanks
    EG       
    • 7 replies
    • 361 views
  4. egp8111 added a post in a topic Leading Edge Extensions   

    I added the plastic KF leading edge to my KF III. Easy to install.  You could probably even add it without recovering the entire wing.  Climbed like a shot and would easily go through the red line with a 912ul.
    Skip
    • 0
  5. egp8111 added a post in a topic Latex Paint   

    EAA has a good webinar on using latex paint. Look in the archives.
    • 0
  6. egp8111 added a post in a topic Tailwheel Springs   

    The two leaf spring should serve you well. Most of the problems were with the single leaf spring.. I ordered the thre leaf and only used two on my KF III. No problems.
    • 0
  7. egp8111 added a post in a topic Handheld radio issues   

    Engine is a 912. With. Muffler
    • 0
  8. egp8111 added a post in a topic Handheld radio issues   

    I've used the settings in the manual for headset use. The internal mic is not hot when the headset is plugged in. I've tried it with and without a flightcom intercom, doesn't seem to make any difference. It must be ambient noise, I can throttle back and people can hear me much better. I can really hear the background noise in the headset when I key the mic.
    I've ordered a leather mic muff , I try that first then go to a high noise intercom.
    Thanks
    Skip
    • 0
  9. egp8111 added a topic in Avidfoxflyers General Hangar   

    Handheld radio issues
    I can't seem to get a handheld to work worth a darn. I can receive great but when I transmit there is so much background noise I'm almost unreadable. People can hear me fine on the ground or when I have the power pulled back. It's not interference noise its background noise. I can't believe my airplane is much louder than any other. I,ve triied different radios and headsets but nothing seems to help. Can someone suggest a set up they have had success with ?
    Thanks
    Skip
    NC
    • 7 replies
    • 455 views
  10. egp8111 added a post in a topic Running 912 without prop   

    about 450 hrs. Currently running an Ivo three blade. Had a three blade wood before. It feels like it's banging at idle. Smooths out above 3000 rpm and runs smoother but not perfect after I've flown it and it's been up to normL temps. Part of me wants to think carbs but I've had them apart so many times and they are in sync on the gauges. Prop tracks good and the blade pitch is equal. Gearbox ? errrrrrr
    • 0
  11. egp8111 added a topic in Avidfoxflyers General Hangar   

    Running 912 without prop
    I'm running out of ideas to get a 912 to run smoothly between idle and 3000 rpm. I've tried all the recommended solutions. I've had the carbs off and apart some many times I'm about to wear out the screws! I've synced it to perfection but it still runs rough between idle and 3000 rpm. So now After reading on line I'm thinking maybe the gearbox is out of spec and needs rebuild. But before I go to the trouble of pulling the gearbox I wondering if running the engine without the prop would indicated rather the gearbox was the problem. I'd now it is very easy to overspend the engine w/o the prop on, just wondering if anyone had any experience with this.
    Thanks
    EG
    • 3 replies
    • 376 views
  12. egp8111 added a post in a topic Another impressive two stroke flyer   

    I have a 1993 model S7 that had a 582 in it.  It flew very well with the motor but I changed it out for a 912ul.  Cruise speed went up some but  TO and climb remained about the same.  It was lighter and more nimble with the lighter two stroke but still sluggish by KF and Avid standards.  Fun airplane still
     
    Skip
    NC
    • 1
  13. egp8111 added a topic in Avidfoxflyers General Hangar   

    *&%^#$@ radio !
    I've been trying to get a handheld radio and headset to work in my S7.(912)  I've tried a Icom A-12 and a Versa with different headsets.  They both are great on the ground with the headset.  I can receive very well in the air but my transmissions are full of noise.  Both radios and headset combinations do about the same thing.  I think it is background noise because everything sounds clear on the ground with the engine running and they receive so well. I have a wind muff on the mic and have tried a leather cover over that but no good.  Any suggestions ?         
     
    Thanks
    EG
    • 3 replies
    • 407 views
  14. egp8111 added a post in a topic 6" Pneumatic Tailwheel   

    I'll take it. 
    I PM'ed you for details
    thxs
    EG
    • 1
  15. egp8111 added a topic in For Sale and wanted, you got it, I want it   

    KF 912 exhaust, muffler, mount. 2 blade Warp Prop for sale
    complete exhaust system off a KF IV motor mount off same (slightly bent but easily repairable alum. pipes for the radiator system 2 blade Warp Drive prop(off 582) PM me if interested for pics EG
    • 0 replies
    • 337 views