flyapart

Members
  • Content count

    5
  • Joined

  • Last visited


Community Reputation

0 Neutral

About flyapart

  • Rank
    Newbie

flyapart's Activity

  1. flyapart added a post in a topic Bad fitting lift strut brackets.   

    I talked to John Mcbean an he really couldn't give an answer. He offered to send me more brackets. I just wanted to get imput from  someone who has had a similiar problem! If this is an ongoing issue with these new style brackets? Just looking for info anywhere I can get it, trying to make sure it's not something I'm doing wrong. and yes I've tried Team kitfox same answers. I guess I'm at a work stoppage untill I ship these back. Thanks guys for the effort!
    • 0
  2. flyapart added a post in a topic Bad fitting lift strut brackets.   

    Pictures really don't show much detail as the gap is hidden by the hose clamps. My question is has anyone else experienced this problem of  getting the bracket to sit squarely around the spar tube without a lot of distortion of the bracket. I have to really tighten the hose clamps to the point of breaking and I still can't get the bracket to sit properly around the spar! There seems to be too much of a gap where the bracket meets the bottom of the spar. Also it doesn't seem to fit squarely to the spar.
    • 0
  3. flyapart added a post in a topic New build   

    The brackets take a heck of a lot of force to get them to lay against the spar. This causes the sides of the bracket to flare outward when you tighten the hose clamps. The top sides of the bracket pull awway from the spar along the top rivet line. Is this an on going problem with these brackets. Also how much of a gap should there be where the bracket meets the spar bottom?I have 1/8 plus gap
    • 0
  4. flyapart added a topic in KitFox General Forum   

    Bad fitting lift strut brackets.
    I'm having trouble getting the lift strut brackets to fit the spar without distorting the sides of the bracket I'm using hose clamps as per instructions,but I can't get the side of the bracket to lay flush when the strut is bottomed out against the spar (1/6th gap). The top row of rivit holes pull away when the clamps are tightend. Is this a regular thing with to new style brackets? I need to apply a lot of pressure to get the bracket o lay flush against the sides of the spar. This looks like it will cause problems trying to drill for rivets . It feels as if the bracket is not made correctly.
    • 5 replies
    • 353 views
  5. flyapart added a topic in Introduce yourself   

    New build
    I'm having trouble with the lift strut brackets on my KF supersport. Is this a regular problem with the new style brackets? I'm just about ready to send them back to the factory. I feel they are not made correctly.
    • 2 replies
    • 521 views