Sign in to follow this  
Followers 0

Anyone know anything about car A/C ?

10 posts in this topic

Posted

My ac clutch coil burned up so I replaced it . I'm still not getting any power to my ac. The clutch spins free and has the right gap . I can't for the life of me figure out what to look at next . All my fuses and relays are good and I changed the pressure switch and still nothing. I don't want to take it to a shop so this is my last hope is that someone here can tell me what else to look at . 

Share this post


Link to post
Share on other sites

Posted

Jump power to the coil and see if the compressor runs, IE does the low side hose get cold? If it does not most likely another safety switch is keeping it from running. Other than that you will have to back track and see where the power stops and fix what ever is causing it. Also make sure the coil is properly grounded. Mike

Share this post


Link to post
Share on other sites

Posted

Only one pressure switch in the system. The coil doesn't even have power going to it 

Share this post


Link to post
Share on other sites

Posted

If its low on Freon the clutch  not turn on something to look at. Some times you can get a DIY can and start filling it up That should kick the compressor on.

Share this post


Link to post
Share on other sites

Posted

Is ther power to the new pressure switch?

Not unheard of to get a bad replacement part.  Double check the switch.

If that was replaced the system was open and the refrigerant was released.  Was it recharged?

Share this post


Link to post
Share on other sites

Posted

Here's what happened . Alternator and battery were going out and during that time the ac stopped working . Diagnosed the clutch coil as bad . Replaced it and still no ac after putting in a new pressure switch. The clutch oil was literally fried. My pressure switch is a 3 wire and controls the high and low . I've heard that some newer cars ac is through the ecm too . Everything is checking out as good . I'm going to my buddies shop today to check my refrigerant level . Nothing was opened during the replacement, I was able to replace the coil with the compressor still in . It's in a 2008 Saturn Astra. I can't find anything else wrong with the system . It just went from working to nothing . The clutch still has plenty of life left and spins free. I've done ac stuff but this is beyond me . I checked my refrigerant level with a cheap gauge and it seems to be where it should be bit that's why I'm also going to test it with real gauges. 

Share this post


Link to post
Share on other sites

Posted

What about your manual switch on the Dash?  Will the heater or fresh air blower turn on?  Do you have power to & from switch?  Just guessing.  EDMO

Share this post


Link to post
Share on other sites

Posted

Yeah that's what I've already gone through now I gotta check my pressure and hope its just low . The new coil came with both black wires so figuring out wich is positive should be interesting. It's the right coil but wrong connectors since it's meant for a variety of cars . 

Share this post


Link to post
Share on other sites

Posted

Well got one thing figured out . My low pressure switch is ran by the ecm . Hopefully a little charge and it's all up and running.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0